Digital Dashboard for ATV

Here we discuss projects and post pictures of projects

Moderator: Fawteen

User avatar
Fawteen
Moderator
Posts: 1107
Joined: Tue Dec 07, 2004 8:28 pm
Location: East Overshoe, Maine
Contact:

Digital Dashboard for ATV

Postby Fawteen » Thu Jan 18, 2018 1:47 pm

A neighborhood kid has a Honda TRX400EX ATV that he bought used. Very used. Over the last couple of months, he and I have completely rebuild the rear end, new axle, bearings, sprocket, hubs and seals. Not cheap, but it should outlast him now.

He's been lobster fishing with his Grandfather and had saved up a pretty fair stash of money so after getting it fixed mechanically, he had a couple of other odds and ends he wanted to add. One was a speedometer and tachometer. The ATV didn't come with any gauges and wasn't set up for them in terms of wiring or drive cables.

After a little noodling around we bought This unit from Amazon. Speed, tach, gear position, fuel gauge, turn signals, odometer and neutral indicator, all in one nice little package.

Of course, it's a Chinese product and the "documentation" that came with it consisted of a few lines of Chinglish and a blurry pinout diagram that really didn't tell you much. After much asking around on the innerwebz and surfing YouTube, I found enough information to get the tach and speedometer (and therefore odometer) wired up, working and calibrated.

The speedometer uses a Hall Effect sensor to pick up it's signal from magnet(s) mounted on the rim of a front tire. You could use any rotating assembly that moves at ground speed (rear tire, axle, sprocket) but the front tire worked best for this application.

Image

The first hurdle was figuring out how best to mount the magnet(s) to the aluminum front rim. After thinking about various options and asking around, I decided to drill some divots in the rim just deep enough to provide a mechanically secure place, and then bedded the magnets (I eventually decided to go with 6) in JB Weld. The unit came with two magnets, I bought more of the same dimensions. The initial approach of a single magnet worked but there was a good deal of lag involved. 6 equally spaced magnets gives a good response.

Image

After looking at various options, I decided to mount the pickup under the bolt that held the caliper dust cover on. That way the sensor can be adjusted to almost touching the magnets if needed and it's somewhat protected by the wheel and suspension components.

Image

Wiring the plugs on the gauge took some noodling, research and trial and error as the instructions were pretty much useless. There are 4 connectors. The necessary connector shells and pins to connect to the plugs on the gauge unit are available HERE as are the crimpers if you don't have a pair already.

The 9 pin connector has power and inputs for the tach, turn signals, fuel gauge, neutral light, and high beams. The ATV doesn't have lights, turn signals, or fuel gauge so those were left unused.

The 6 pin connector is for the neutral light and the first 5 gears of the shift position indicator. Not used on this machine.

There's a 2 pin connector for 6th gear, also not used.

The Hall Effect sensor for the speedometer has it's own 3 pin connector.

Figuring out what was what on the 9 pin connector needed a bit of interpretation. First, the diagram shows +12v on the red wire (pin 4) and ground on the green wire (pin 6). Yep, pretty standard. Except that it doesn't work until +12v is also jumpered to pin 5, which I discovered by probing around with 12 volts to see what went where.

Also, the tachometer input is labeled as "speed" which is pretty confusing until you realize they don't mean speedometer which has it's own separate plug.

The next issue was finding out what signal was needed to drive the tach function. I initially hooked it to the ignition module side of the coil. I did get the needle to move, but it was obvious that it was WAY off, idling at an indicated 6K RPM.

I searched YouTube and found a guy that had the same problem and cured it by building a filter (capacitor and resistor) to cancel the noise spikes. Tried that. It also canceled the ignition signal and the tach never moved. Crap.

Surfed YouTube some more and found a guy wiring a Honda motorcycle that said it had to be hooked to the "ignition pulse generator". Never heard of such a thing but some more surfing found a wiring diagram for the ATV and sure enough, there's a pulse generator. Traced out the wiring and found it, piggy-backed the tach input to it, and PRESTO! Got signal and the tach responded, but still reading pretty fast with a 2K RPM idle.

So next was programming the gauge to calibrate it to the inputs I had.

Tach problem was solved by telling the gauge it was a 2 cylinder. It's a single, but uses a "lost spark" ignition so the signal had to be halved.

Speedo is calibrated by entering a constant. Problem is, the instructions provide absolutely NO guidance as to how to determine what that constant should be. They give one example for a certain tire diameter, and number of magnets mounted. Some folks less math-challenged than myself were able to create a formula that let me extrapolate from that to come up with at least a ball-park number.

All that's left to do is check my ballpark setting against a GPS speedometer. I downloaded an app for my phone, just need to get a little warmer out for the calibration runs.
What do you mean I can't do that?

Return to “Shop Projects”

Who is online

Users browsing this forum: No registered users and 1 guest